Large Scale Central

Trouble Shooting Aristocraft ART-5471 Train Engineer Reciever

LSC member @Rich_Niemeyer graciously offered us his collection of Train Engineer components for the cost of shipping, advising us in advance that at least one set was functional. In fact, we are very close to having two functional sets!

Kid-zilla and I located the manual “Train Engineer Walk-Around Control System” using this thing “Google” that @PeterT reminds me can, in fact, be quite helpful! We successfully paired one set, but had an issue with the receiver, ART-5471, with the second. We opened it and compared it to the working one and quickly found the power chord had broken free.

After soldering it, we verified the receiver powered up; however, the code set LED (visible in the instructions) never lit when we pressed the button. We did not see any obvious damage to the circuit board or any of the components on the other side.

Has anybody ever repaired one of these receivers? Is it worth trying, or should I avail myself of the receiver on e-Bay? The walk-around feature is pretty cool, and it will enable us to actually operate the Triple O. I’d love to someday convert some of our locos to R/C, but this is a pretty cost-efficient interim solution.

Thanks in Advance!


I have owned my TE for 20 years. One thing I have noted is that LED’s, at least on the hand held TX can fail but the channel is still operating and sending to the RX (5471). Possibly the LED bind/signal has failed. Have you tried going through the binding process and seeing if you can operate the RX ? Also have a look here (if you haven’t already) TE Programming
Hope you get it fixed, lovely bit of kit. After 20 years I have just migrated to battery/RC.

I agree with Max however one other thing you can try is rapidly pushing the code link button and see if you get any green LED flash at all. Sometimes the push button switch contacts get dirty and a simple push will not allow them to make contact.

I concur with Rooster that the buttons get flaky. If you get offered a spare TX grab it, as they fail first, I think.

My pal Jerry still uses his on his garden layout. Works fine.

I also have a 5471 sitting under other stuff that was working great when I took it out of the Pacific. You can have it for shipping. (Bet I’m not the only one.)

I also have a 5490 onboard RX when you want to try r/c in a battery loco.

I also use TEs and have several, including some that have failed. I have seen where the output transistors get “leaky” and the voltage can creep when there is no load on it, such as on a point-to-point.

I’ll take the 5490 if no one else wants it.

Thanks everyone. Let me dicker with it a bit this weekend. I should note that I did get a little over a volt across the outlet terminals, so something is “leaking” through the circuitry.


IIRC, I had replaced the small capacitor across the output on one of them and this did seem to help. Also, if you get one that “leaks” you can put a resistor across the output so it always sees a load. Something like 100 ohms at 20 watts should be OK.


First, thanks again, everyone, for the tips.

Today I did the following:

  1. I opened up the receiver, cleaned off all the dust with rubbing alcohol, and manipulated the code link button to clear any grit. I also reinspected the circuit board for obvious breaks or evidence of leaks from the capacitors (one of the power supplies had capacitors that oozed liquid and burnt!). No joy.
  2. I tried to see if the issue may be the transmitter, with a dead lead to the code link LED masking the issue. Nope.
  3. I tested the voltage drop across the code link LED, figuring it would be 0 volts normally but register a voltage drop with the code link button depressed. It was 0 volts across the LED regardless.

Anything else I should look at, or should I ready my PayPal account to compensate Pete (@PeterT ) for shipping?

Have a Great Weekend!