Large Scale Central

[SOLVED} LGB 20670 does not move forward or reverse

I have an older LGB 20670 track cleaning locomotive that I have used a number of times in the past. However, I haven’t run it in quite a while. I tried running it to clean the track of my Christmas layout this year and while the cleaning motor runs, the loco does not move forward or backwards. The lights all come. I am wondering if perhaps the motor is bad and needs to be replaced. If so, I have been searching for an exploded view of this loco in order to see how to get at the motor but can’t find one. Any help here is much appreciated.

If the motor is running but it isn’t moving, maybe the drive gears are stripped our not engaged? While I don’t own this locomotive, I have found with other LGB locos a good drop or misassembly after maintenance can either dislodge the motor or leave it loose to disengage the gears.


I’ve never dropped the loco or taken it apart. I am assuming that the running motor (not the track cleaning motor) might have given up the ghost. Does anyone know which motor it takes?

Trainli ( TRAINLI - LGB and G-scale Experts ) is my go-to source for parts. You should be able to enter the model number, too, to get a list of what you might need. They also rebuilt one of my Ancients (an '80s vintage model) at a very reasonable price.


Yes, I’ve just ordered a motor from them for this loco assuming it is the main motor (not the track cleaning motor).

I received the new motor today from Trainli. However, for the life of me I cannot see how to remove the motor casing from the locomotive. Has anyone else performed this operation?

I removed the 2 braces at the front and back of the motor casing as seen here:

I then tried to lift out the motor casing as seen here:

However it appears to be attached/obstructed at the ends here and I don’t see anyway to free it:

Any suggestions are greatly appreciated.

I got it! The motor is now replaced with a new one and all is well.

Glad to hear it all worked out! I have found that sometimes a brief break…a frustrated post here…and another assault with a screwdriver have been all it takes to get my LGB iron horses up and running again!