Large Scale Central

QSI Programmer Install

Trying to install QSI programmer on Windows 10.

Getting through everything in QSI manual, but cannot get drivers to locate the new device.

Drivers are in SiLabs folder

Anyone have any thoughts?

Thank you


They have instructions on how to do it on the site.

You have to put windows 10 (and 8 for that matter) in a mode to accept an “unsigned driver”… (The SiLabs people are too cheap to pay to make a “signed driver”).

Anyway, follow the instructions on the QSI solutions site, they are there.

If you get stuck, come back here, I have it running on everything from XP to Windows 10.



Thanks for the help…

I tried it once that way but will start over with clean slate this p.m.


Windows 10 still no go with Driver Signature and Norton Disabled.

Suspect downloaded files might be in incomplete? But how would I know?

I went back to the Windows 7 and ran into the same message,

“WinZip was able to extract only part of the file because it contains invalid or missing data”

Does that mean anything?

Its bad enough not to be able to get GWire receivers…

I found the problem (me)… WinZip was defaulting to file in a different location. I was able to install drivers and updates!

Tomorrow first attempt at programming. :slight_smile:

good deal, been there and done that on the download ha ha!

I thought the GWire receivers were back in stock? Hmm, guess not yet… The QSI forum should have specifics.



Now I’m getting the “Unable to read Mfg. ID” on retrieve Loco information on Q2 and CV Manager.

I don’t understand the replace chip from earlier version (1-6)… this a new Titan should it not be updated

Where and how to get the new chips? Is the installation tricky?

I bought multiple 4 Titan units, so I’m assuming I’ll need more.

Luckily I have only installed one Gwire so far. I wonder if they’ll all need the 7 version?

If there’s a way to test and install before they go into the locos, that that would be easier.

I think you need to remove the GWire receiver when on programming track.

So, can you read and write any CV’s?

So first, did you update the firmware in the programmer? You want to check this and make sure you have the latest version.

This will also prove the communication from the computer to the programmer.

Next, I would make sure the wheels are clean, and all lights and smoke are off.


Michael, were you ever to get past the “Unable to read…” error? I’m getting the same thing on mine.

I tried it on two platforms; first my XP laptop, them my Win10 laptop.

On the XP, I can communicate just fine with the decoder under CV Manager. I used it to set the sounds and motor parameters and it worked just find and dandy. Alas, the sound file that’s on it is a .q2 file, and I’d like to upgrade it to the .q3 file. On my XP laptop, I’ve got two versions of the upgrade software. The older Q2 upgrade, and the latest Quantum upgrade. When loading the sound file into either version (no decoder attached), I get more whistles under the later software, two of which are East Broad Top whistles. Naturally, I’d prefer to use the later version of the software so I can get those whistles. Alas, when I connected the decoder to the programmer (direct 2-wire connection), I got the “Unable to read…” error. I tried on the older software and got the same error. I tried CV Manager again to see if something was wonky with the interface, but could read and write CVs no trouble.

Thinking I should probably upgrade to the latest version of everything anyway, and having a newer laptop, I downloaded and installed the driver for the SiLabs box on my Win10 machine. Following the instructions for installing the driver, it went smoothly and appears to have worked–at least when I go to the control panel, it shows the interface as being connected. Unfortunately, when I launched Quantum Programmer, I got the same “Unable to read…” error I had gotten on my other computer. When I fired up CV Manager, I don’t think it’s communicating with the decoder. I can’t get a command window to run the decoder.