Large Scale Central

Linking problems with te revolution 57000s and my spectrum260mogul81487

my spectrum circuit board( 260 mogul) does not link to the te revolution 57000s receiver;I’m using battery power; what could be the problem?

Was it linking before or is this on first try after install?

It never linked; no flashing loco light or led on the receiver; I had voltage going to the receiver and the loco circuit board.

Assuming that the wireing is correct there can sometimes be a foulup that involves the MU’ing feature.
go through the linking procedure then try this.

Press menu 1 time
On that screen go to line 3
MUSU, select that
scroll down to CAB # SU single unit, select that
Press menu 2 times to exit.

Go through the linking proceedure again.

Don’t know if this is the issue but could be.
Good luck

Remove the receiver from the engine and do a bench setup. If it doesn’t link now, you have a receiver problem.

I sent the receiver back to te revo. and JK ,the tech person, tested it ; He said it checked out fine.I got it back Tue. plugged it into the circuit board and tried rick’s suggestion for linking however, still no link-up.
The loco has 2 pigtail connectors that plug into the tender;That is where the main circuit board is located. Could there be a problem with those connectors? If so ,how would I check it out?
I did have voltage between battery input to receiver and the circuit board.JK said to check voltage on J1-1 and J-12 on main circuit board; There is voltage. Bachmann isn’t much help either. Any suggestions ? Thanks for your help

Do you still have the non-pnp adapter board? If so, use it to power the receiver on your bench. Connect the reset button. Hold the reset button until you get the red LED to light. Then momentarily, touch the linking command on the transmitter.

I plugged the non-pnp adapter board into the 12 pin header of the receiver; the red led started flashing then went solid red ;I touched the linking command and it did’t link