Large Scale Central

LGB Mogul does not run with new Blunami decoder only when placed on track or rollers [SOLVED]

Going out on a limb here… I’ve got an issue with a new Blunami 4408 installation I just completed in one of my LGB Moguls. I’ve done one of these 4408 decoder installation on another LGB loco and it runs great! I installed a new Blunami 4408 in the tender and the installation went just fine. I am running on battery power and removed all the track power pickups, brushes and shoes from the loco. However, with this new (second) installation, the LGB Mogul runs just fine when it is laying on its side with very little throttle given but when I place it on the track or on rollers it does not run at all. I can hear the Blunami clicking away as I increase the throttle speed but the wheels don’t move. I’ve included a short video here demonstrating this issue. I’ve reached out to Soundtraxx but have not heard back from them yet. Hoping perhaps someone here might be able to shed some light on this issue.

Assuming there is no power connection, or short on that test rail, it sounds like a current loss problem.

If there is a power connection, or shorting condition on the rail, try it on completely isolated rail to confirm power is not leaking into the rails from somewhere. If it runs on isolated rail then you might have missed a track pickup or two.

The tests I’ve done are on an isolated 24 inch section of track sitting on my bench. I’ve tried both with the loco sitting on the track and on rollers on the same track section. There is no power connected to it. The loco / tender is wired to used the Blunami decoder via battery power only.

How sure are you that the locomotive worked well before the install. Maybe one of the gears split. With no mechanical load works fine. Put a load ie (on tracks) and the gears slip. Just a thought.

Ok…it now indeed appears to be the connection between the tender and locomotive. I have 2 of these LGB 2028D Moguls. I took the tender with the Blunami installed from Mogul 2028D #1 which is not running on the rollers or track and connected it to Mogul #2 placing it on rollers. Bingo! It runs just fine! I then placed Mogul 2028D #1 back on the rollers and connected up the tender and discovered that when the tender is moved forward the wheels of the loco do not spin. However, when I pull the tender back the loco wheels spin just fine. So, it does appear there is an issue I am guessing either in the connecting cable itself or in the cable plug or connection socket. Here is a test video I made demonstrating this test:

I run all my LGB engines on Rail Pro with battery power. I have removed all the pickups on both the engines and the tenders, I did not want to have the track power option by switching from track power to battery power. Did you remove the brass wheel wipers in the engines main drive wheels, this includes the track sliders and the brass wipers that make contact to the drivers. They just lift out with the engines bottom cover removed, leaving these in would defiantly.cause a problem when placed on the track. I will say I know nothing about the Blunami Decoder, so it may have some electronics that are different, but you did say it works on one engine, but not this one. I will say here that when I convert my engines to Rail Pro I remove all the LGB electronics and start from scratch with the new stuff, this would also be done if I was going DCC also.

I have had to fix one of those cables for a friend’s mogul. The cable just came off the plug that sticks in to the tender. Not a great design. Check that all the wires and connections are good? Check that one of the pins on the tender is not bent (you’d be surprised how often that happens.)

Yeah. I did another test this morning that hopefully shows me that the issue is not an issue with the pins within the tender.

I connected the tender with the Blunami installed to my other LGB 2028D mogul. Put the mogul on the rollers, turned on the Blunami running the loco on the rollers and moved the tender close and further away from the loco. There was no interruption in the wheels turning on the loco as there is with this tender and my other 2028D. To me, this seems to indicate that the jack/socket in the tender is good with no issues. This seems to indicate to me the issue is either the wire harness itself, or the harness plug that plugs into the tender jack or the connection of the wire harness within the locomotive as there is some movement in the harness in the locomotive.

The harness is different than the ones on my newer LGB moguls that have a plug on both ends of the harness that plugs into both the loco and the tender. I’ve reached out to Trainli to see if this harness connection is available but have not heard back yet. My guess is that they are not.

More sluething to follow.

1 Like

Sounds like your getting close to figuring it out.

As I said in a post above, I remove all the LGB factory wiring (or any brand name manufacture) when going to DCC, or a battery RC system, this will pretty much isolate the problem. Using the manufactures electronic of the engine you have, usually proves to be a problem and makes it hard to isolate problems. I even change all the lights in the system to LED’s where my new system is designed to work, older incandescent bulbs can draw too much power from your new system you are installing. These things can either by your problem, or not, just things I do to lessen problems.

Yeah…I’m starting to lean that way.

I soldered a new harness from the circuit board in the loco to the tender and things got even worse. The wheels would rotate 3 or 4 times and then stop. I am beginning to think that perhaps the whole cirucit board and wiring in this very old loco is the culprit here.

When I take power to the motor off the Blunami and wire directly to the motor it works great! You can see from the short video here.

I am now thinking that perhaps I should run new wiring (as you suggest John) to the motor and the front light from the Blunami and bypass the internal circuit board all together. I am thinking there shouldn’t be an issue with this? Does anyone else see that as an issue?