Large Scale Central

Another Airwire/Phoenix problem

I didn’t want to confuse TomL’s thread so here’s another on the same kind of topic.

My pal has an MTH GG1 with an Airwire G3 and some kind of Phoenix card.

First - can anyone identify the Phoenix board? I can’t really get at the bottom to see any more.

The loco was running and sounding fine for about an hour, then the sound went off and a while later the loco slowed and stopped. We assumed the battery might be getting low, but the charger showed no sign of charging.

I took the body off and found those 2 cards, some decent wiring and some rubbish, including duct tape insulation, wire nuts, and weird loose wires. Testing the battery showed 15.5V, which isn’t bad for a Cordless Renovations 14.4V Lithium pack. Tracing the power to the G3 card all seemed well.

Initially when I powered it up and turned on the TX, we got a green LED and a red LED and the loco tried to move on the table top when I gave it some power. No Sound. Then after a bit more fiddling with the wires we got just a blink from the green and no red. No sign of power at the G3 interface. I took out the red + and got power, but when I tried to push it back we got a spark and nothing. I think the battery protection was cutting power due to a short.

So after more inspection and testing, we got the green LED and then I found there were hot spots on the board - very hot! Looks like it might be fried?

Any thoughts?

A quick google suggest this is a Phoenix P8 board. $215 and still available.

I’m not sure any Phoenix products are available. That is one messy wiring job. The heat coming from the G3? It’s possible you will need a new G4. G3’s are obsolete.