Forums Website Website
  • Topic: Website slowness, and a warning

    Back To Topics
    (0 rates)
    • December 1, 2020 9:38 AM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      Website slowness, and a warning

      Hey folks

       Over the last couple of weeks, the site has experienced odd slowness, usually in the evening.  I've been tracking it down, and made some change to help.  Watching the site last night, I didnt see any errors like we have been getting the last several days.  Still keeping an eye on it.

       

       And now, a warning.  Complaints about inappropriate content are on the rise again.  You know who you are, you've been warned and suspended before.  Knock it off or the suspension is permanent next time.

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 1, 2020 1:45 PM EST
      • Denver, Colorado
         
      • Posts
        2,508
      • Thanks
        482
      • Thanked
        932

      Bob McCown said:
      ..

       And now, a warning.  Complaints about inappropriate content are on the rise again.  You know who you are, you've been warned and suspended before.  Knock it off or the suspension is permanent next time.

       

         Dear Fellow Trainsters....I have been selling off a lot of my extra train stuff, having set up an improvised train store in the garage, and have had the very rewarding experience of not only making back some money but getting four or five families with five- to nine-year-old kids and grandkids started out in trains. (I'll send a picture and details along at some point.)

       

         I've recommended LARGESCALECENTRAL as the place to go for great ideas, help, and maybe buy more supplies I don't have for them.

       

         The parents have asked if the site is safe for kids, and I have said, "Oh yes it is," (the kids being supervised of course).

       

       

      ____________________________________

    • December 2, 2020 6:51 PM EST
      • Curmudgeon at Large, Lynn Haven, FL
         
      • Posts
        2,288
      • Thanks
        87
      • Thanked
        298

      Bob McCown said:

      Hey folks

       Over the last couple of weeks, the site has experienced odd slowness, usually in the evening.  I've been tracking it down, and made some change to help.  Watching the site last night, I didnt see any errors like we have been getting the last several days.  Still keeping an eye on it.

       

      Thanks for keeping up on this Bob. Site has been better the last couple days.

      ____________________________________

      We don't stop playing with trains because we grow old, we grow old because we stop playing with trains.....

       

    • December 2, 2020 7:11 PM EST
      • Not one of the WannaBe's,
         
      • Posts
        6,083
      • Thanks
        1,951
      • Thanked
        884

      But the load time is creeping back up already

    • December 2, 2020 8:56 PM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

       

      Well, the highest pageviews happen between 7 and 9pm.  Traffic more than triples.

       

       

      That's average pageviews per minute.  The middle spike is Nov 30, the one on the right is Dec 1.

       

      We get a *LOT* of traffic in the evening.

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 2, 2020 9:44 PM EST
      • Pleasanton, CA
         
      • Posts
        1,432
      • Thanks
        1,805
      • Thanked
        1,230

      Those spikes are probably chat. Lots of page loads to see the latest post.

    • December 3, 2020 9:10 AM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      Yea, about half that spike is chat, the rest is forums traffic.  

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 16, 2020 8:03 PM EST
      • Not one of the WannaBe's,
         
      • Posts
        6,083
      • Thanks
        1,951
      • Thanked
        884

      Tried to get on today between !!:30 and 12:00 noon, no access. tonight from 7:05 till 7:53 continuous refresh to see how long it is down. Error message received:

      Fatal error: Uncaught exception 'Zend_Db_Adapter_Mysqli_Exception' with message 'Too many connections' in /home/rmccown3/public_html/application/libraries/Zend/Db/Adapter/Mysqli.php:352 Stack trace: #0 /home/rmccown3/public_html/application/libraries/Zend/Db/Adapter/Abstract.php(448): Zend_Db_Adapter_Mysqli->_connect() #1 /home/rmccown3/public_html/application/modules/Core/Bootstrap.php(112): Zend_Db_Adapter_Abstract->query('SET time_zone =...') #2 /home/rmccown3/public_html/application/libraries/Engine/Application/Bootstrap/Abstract.php(256): Core_Bootstrap->_initDb() #3 /home/rmccown3/public_html/application/libraries/Engine/Application/Bootstrap/Abstract.php(207): Engine_Application_Bootstrap_Abstract->_executeResource('db') #4 /home/rmccown3/public_html/application/libraries/Engine/Application/Bootstrap/Abstract.php(150): Engine_Application_Bootstrap_Abstract->_bootstrap(NULL) #5 /home/rmccown3/public_html/application/libraries/Engine/Application.php(149): Engine_Application_Bootstrap_Abstract->bootstrap(NULL) #6 /hom in /home/rmccown3/public_html/application/libraries/Zend/Db/Adapter/Mysqli.php on line 352

      Guess all we can hope is you get the new rendition up soon. Seems these access issues came after we were told the software would no longer be supported and you were looking for a new deal. Frustrating I only have time to complain when I can finally get onto the site that I use for a little relaxation

    • December 16, 2020 8:14 PM EST
      • Candlewood Valley, Connecticut
         
      • Posts
        14,111
      • Thanks
        1,821
      • Thanked
        1,345

      I reported that same error to Bob a few days ago, the day Google went down. Within an hour LSC was back. Don't know if Bob did anything or it resolved itself.  Google was timing out for me earlier this evening, so it might be ad service issues.  Seems connected.

      ____________________________________

      www.cvsry.com www.cvsry.com

    • December 16, 2020 8:45 PM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      Yea, the software being unsupported is causing issues.  A lot of the packages 'call home' to get licensing info, and to send usage statistics.  Since they dont support this package any more, a lot of those endpoints are dead, and cause issues.  I ferret them out as I find them, but they're purposely obfuscated.

       

      I dont have a block of free time to import to the new package, but I dont see where I have a choice at this point.

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 17, 2020 5:32 PM EST
      • South Central , PA
         
      • Posts
        15,291
      • Thanks
        3,245
      • Thanked
        1,859

      Bob McCown said:

       I ferret them out as I find them, but they're purposely obfuscated.

       

      Wow,

       This is HUGE for me as I learned a new word !  Rooster tends to "obfuscate" things just like the ferrets!

       

       

       

       

      This post has been edited by ROOSTER: Obfuscate can also be used as an adjective ....YES!!!

       

      Thank you BD !!

    • December 17, 2020 8:19 PM EST
      • Not one of the WannaBe's,
         
      • Posts
        6,083
      • Thanks
        1,951
      • Thanked
        884

      Causing issues and getting worse. over an hour tonight to log on. Rant left in a blank chat. Email me if the site starts working again

    • December 17, 2020 8:21 PM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      I was watching as that happened, it went down almost exactly at 7:00 and was timing out for about an hour and 15 minutes.  That does not correspond with a spike in traffic or anything.  There's some process that runs at that time that's REALLY screwing things up.  Im at my wits end about this right now.

       

      Here's the traffic graph with the arrow pointing to the hour we were down.  No giant spike in traffic before it, just normal up/down.

       

      This post was edited by Bob McCown at December 18, 2020 1:29 AM EST
      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 18, 2020 8:25 AM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      I've added Cloudflare CDN to the site (probably won't mean much to many of you), but that should speed up things by at least 10%.  

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 18, 2020 8:51 AM EST
      • Not one of the WannaBe's,
         
      • Posts
        6,083
      • Thanks
        1,951
      • Thanked
        884

      I see you seem to have removed the three pics from the home landing page also.

    • December 18, 2020 8:53 AM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      Yea, that was using a set of plugins from a company that doesnt exist any more, and was taking 3+ seconds *all on its own" to show the pictures.  Annoying.

       

       

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

    • December 18, 2020 8:55 AM EST
      • Not one of the WannaBe's,
         
      • Posts
        6,083
      • Thanks
        1,951
      • Thanked
        884

      I do note even here early in the day the refresh is better

       

    • December 18, 2020 9:47 AM EST
      • East Brunswick, N J RRR#22
         
      • Posts
        1,989
      • Thanks
        203
      • Thanked
        305

      Thanks for all of your efforts on this Bob.

      ____________________________________

      "If I ever go looking for my heart's desire again, I won't look any further than my own backyard. Because if it isn't there, I never really lost it to begin with." - L. Frank Baum

    • December 18, 2020 12:44 PM EST
      • Lancaster, Ohio
         
      • Posts
        703
      • Thanks
        43
      • Thanked
        141

      Interesting, when the site was down two nights in a row (16th and 17th) from about 7:00 to 8:00 I was beginning to think it was some sort of denial of service attack.

    • December 18, 2020 4:00 PM EST
      • Your Host in Littleton, MA
         
      • Posts
        8,017
      • Thanks
        599
      • Thanked
        1,688

      That certainly is possible. I've send up a distress rocket with the ISP to escalate helping figure out what is going on.  The biggest part is that when the server is down, its down *hard* and takes 30+ minutes to recover even to the point I can get to the server itself.  I had the ISP do a hard reset a couple days ago, just to get the machine up.

       

      Whatever is happening isnt leaving any clear fingerprints on what is going on.  Frustrating doesnt begin to describe it.

       

       

      ____________________________________

      Bob, your Site Host and Benevolent Dictator.

Forums Website Website

    Icon Legend

  • Topic has replies
    Hot topic
    Topic unread
    Topic doesn't have any replies
    Closed topic
    BBCode  is enabled
    HTML  is enabled

Add Reputation

Do you want to add reputation for this user by this post?

or cancel

Ads by Google