Forum Sponsorsss


Forums General General Discussion
  • Topic: LGB repair service

    Back To Topics
    (0 rates)
    • July 22, 2020 11:47 AM EDT
      • floral park, ny
         
      • Posts
        7
      • Thanks
        0
      • Thanked
        0

      LGB repair service

      Can anyone recomend a reliable LGB repair center, perfer the esat coast..

       

    • July 22, 2020 10:26 PM EDT
      • Ottawa/Nepean, Ontario, Canada
         
      • Posts
        4,784
      • Thanks
        242
      • Thanked
        360

      "Only Trains"

    • July 23, 2020 7:11 AM EDT
      • Eastern Massachusetts
         
      • Posts
        1,249
      • Thanks
        10
      • Thanked
        116

      What needs fixing?  I do the Eastern LGB repairs for trainli and live in South Eastern, Massachusetts.

    • July 23, 2020 7:37 AM EDT
      • floral park, ny
         
      • Posts
        7
      • Thanks
        0
      • Thanked
        0

      Dan...lgb trolly .....was in storage 18 months..will not run

    • July 23, 2020 10:24 AM EDT
      • Fort Worth, Texas
         
      • Posts
        113
      • Thanks
        3
      • Thanked
        28

      Well it can't be much to get it running again, my LGB engines have set in there boxes for some 25 years and they all ran right out of the box. I did check the gear boxes where the motor gears are and gave them a lube job as I did find the grease had harden somewhat, but not bad. Sounds electrical, did you turn off the power switch on the engine, if it has one, most LGB engines do. Taking the two wires form the transformer and touching the wheels on opposite sides, or the sliders on the engine and see if you get any movement of the wheels. Yes, turn the power on to say 1/2 power. I personally don't feel that something became disconnect in the engine from just being stored, I think it's very simple fix if the engine was running fine the last time you ran it. I hope the ants, or bugs didn't build a home inside it, it happens more times then you think. I would think that someone that lives close to you and knowledgeable of electrical engine repairs would help you with it, it you were close to Ft. Worth, Texas I would be glad to help you, I would feel that helping a fellow model railroader is something we should all do. 

       

      trainman

    • July 23, 2020 10:35 AM EDT
      • Easton , Massachusetts
         
      • Posts
        4,640
      • Thanks
        2,272
      • Thanked
        649

      John Lenheiser said:

      Well it can't be much to get it running again, my LGB engines have set in there boxes for some 25 years and they all ran right out of the box. I did check the gear boxes where the motor gears are and gave them a lube job as I did find the grease had harden somewhat, but not bad. Sounds electrical, did you turn off the power switch on the engine, if it has one, most LGB engines do. Taking the two wires form the transformer and touching the wheels on opposite sides, or the sliders on the engine and see if you get any movement of the wheels. Yes, turn the power on to say 1/2 power. I personally don't feel that something became disconnect in the engine from just being stored, I think it's very simple fix if the engine was running fine the last time you ran it. I hope the ants, or bugs didn't build a home inside it, it happens more times then you think. I would think that someone that lives close to you and knowledgeable of electrical engine repairs would help you with it, it you were close to Ft. Worth, Texas I would be glad to help you, I would feel that helping a fellow model railroader is something we should all do. 

      trainman

      His info under his name says   floral park, ny

      ____________________________________

       My u-tube  My Vimeo

      The light in the tunnel might not be an engine , but a light in the caboose of my own train on my Roundy Round Rail Road !    My empire is complete...I think...

    • July 23, 2020 7:15 PM EDT
      • Fort Worth, Texas
         
      • Posts
        113
      • Thanks
        3
      • Thanked
        28

      Sean McGillicuddy said:
      John Lenheiser said:

      Well it can't be much to get it running again, my LGB engines have set in there boxes for some 25 years and they all ran right out of the box. I did check the gear boxes where the motor gears are and gave them a lube job as I did find the grease had harden somewhat, but not bad. Sounds electrical, did you turn off the power switch on the engine, if it has one, most LGB engines do. Taking the two wires form the transformer and touching the wheels on opposite sides, or the sliders on the engine and see if you get any movement of the wheels. Yes, turn the power on to say 1/2 power. I personally don't feel that something became disconnect in the engine from just being stored, I think it's very simple fix if the engine was running fine the last time you ran it. I hope the ants, or bugs didn't build a home inside it, it happens more times then you think. I would think that someone that lives close to you and knowledgeable of electrical engine repairs would help you with it, it you were close to Ft. Worth, Texas I would be glad to help you, I would feel that helping a fellow model railroader is something we should all do. 

      trainman

      His info under his name says   floral park, ny

      I did say in the post that IF IF IF IF you were close the Ft. Worth, Texas I would be glad to take a look at it. It would be nice IF IF IF IF someone in his neck of the woods would help out a fellow model railroader.  

      trainman

    • July 24, 2020 7:59 AM EDT
      • Eastern Massachusetts
         
      • Posts
        1,249
      • Thanks
        10
      • Thanked
        116

      Jack is 3 hours from me, but shipping would be the lowest as I am close.  There are many who repair LGB equipment, but shipping is costly.

       

Forums General General Discussion

    Icon Legend

  • Topic has replies
    Hot topic
    Topic unread
    Topic doesn't have any replies
    Closed topic
    BBCode  is enabled
    HTML  is enabled

Add Reputation

Do you want to add reputation for this user by this post?

or cancel

Ads by Google