Forums Power and Sound Power and Sound DCC
  • Topic: cleaning loco not fully working with DCC

    Back To Topics
    (0 rates)
    • May 21, 2020 6:58 PM EDT
      • Lansing, US-KS
         
      • Posts
        47
      • Thanks
        1
      • Thanked
        1

      cleaning loco not fully working with DCC

      I have a yellow 20670 cleaning loco with the 55021 decoder directly (push in) installed.  When I run it with DCC, the engine moves forward and back no problem.  But the cleaning motor does not come on no matter which function button I press.  All lamps work using DC, but the flashing lights aren't working with DCC.  My guess is because the cleaning motor isn't running.  

      The loco works with my analog power pack but forward movement is real slow.  The throttle pack only puts out 2.5A which I am told is lower than optimal for this engine. 

       

      I have tried resetting the decoder but still no luck.  The switch in the cab is in position 2. 

      I know I could put a more expensive decoder in there but I don't need anything special with this engine.  

      Any ideas?

      This post was edited by Derailed at May 21, 2020 7:29 PM EDT
    • May 21, 2020 8:05 PM EDT

      •  
      • Posts
        14,706
      • Thanks
        2,669
      • Thanked
        1,556

      Sean has the same loco I believe ....perhaps he knows the answer ?

    • May 22, 2020 5:48 AM EDT
      • Easton , Massachusetts
         
      • Posts
        4,589
      • Thanks
        2,154
      • Thanked
        611

      I do but with out all them bells and whistles .. Calling Dan Pierce .... hopefully he's chime in ..

      ____________________________________

       My u-tube  My Vimeo

      The light in the tunnel might not be an engine , but a light in the caboose of my own train on my Roundy Round Rail Road !    My empire is complete...I think...

    • May 22, 2020 8:36 AM EDT
      • Eastern Massachusetts
         
      • Posts
        1,201
      • Thanks
        9
      • Thanked
        104

      55021 decoder after a reset (CV 55 to 55) will set the decoder to 14 speed steps and address 3.

      Change cv29 to 6 for 28/128 speed steps and try setting your system to 28 steps as some 55021's only did 14 or 28 steps.

      I use long addressing on mine  CV29 to 38, and set engine number to 2070....  cv 17 to 200 and cv 18 to 19.

       

      Note when speed steps between control systems and engines do not match, it is always the lights not working/flaky.

       

    • May 22, 2020 2:12 PM EDT
      • Lansing, US-KS
         
      • Posts
        47
      • Thanks
        1
      • Thanked
        1

      Dan,

      I did as you suggested and no change.  

      I tried my other 55021 again but using your notes. This one works so it must be the decoder. 

      Thank you.  

       

      Is there a way to control the cleaning motor speed in DCC using CVs and voltage adjustments?

      This post was edited by Derailed at May 22, 2020 2:31 PM EDT
    • May 23, 2020 11:47 AM EDT
      • Eastern Massachusetts
         
      • Posts
        1,201
      • Thanks
        9
      • Thanked
        104

      The cleaning motor always runs at full track voltage.  I once found a 20670 without any boards and installed a zimo decoder for DCC operation.  What I found is now I can clean in both directions and by running the cleaning motor at full track voltage via a relay and diode bridge it cleans extremely well with the engine running slow.

      My other/original TCL (Track Cleaning Loco)  is DC only and does not clean any way near as well as my DCC version.

    • May 23, 2020 3:01 PM EDT
      • Lansing, US-KS
         
      • Posts
        47
      • Thanks
        1
      • Thanked
        1

      Thanks.  This one cleans very well now that it is getting the full power.  The engine motor just wasn't getting enough power with my old DC transformer.  Forward speed was so slow I often had to give it a nudge, particularly on slopes and turnouts.  

Forums Power and Sound Power and Sound DCC

    Icon Legend

  • Topic has replies
    Hot topic
    Topic unread
    Topic doesn't have any replies
    Closed topic
    BBCode  is enabled
    HTML  is enabled

Add Reputation

Do you want to add reputation for this user by this post?

or cancel

Ads by Google