Forums General Problem Solving
  • Topic: 23182 sound board not working

    Back To Topics
    (0 rates)
    • July 8, 2018 10:38 AM EDT
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      23182 sound board not working

      I have a 23182 Mogul whose sound board does not funtion starting just this week. There is occasionaly a pssst pssst sound (two 'words') when loco is reversed from standing position. Otherwise no sound of any kind. All switches on loco and tender are in correct positions. Volume control set at maximum. Loco is running on track power.

      How should I go about making an analysis of the problem? I have a multimeter and am a little bit familiar with very basic electricity.

      Are replacement sound boards available anywhere?

      This was my first LGB loco and have had it for 20 years. Hate to lose an old friend.

      Roger Bush

      Ruidoso  NM

    • July 8, 2018 4:46 PM EDT
      • Pittsburgh, Pennsylvania
         
      • Posts
        10,049
      • Thanks
        83
      • Thanked
        597

      I would check the wiring going from the locomotive to the tender. The wires broke on mine, but the insulation was in tact, so the connector looked good. Once I repaired the connector I had sounds again.

      ____________________________________

      Shannon car Shops
      Home of the infamous leg lamp

      I.A.R.R.R. Member #12

      and King Butt Modeler

    • July 9, 2018 7:44 AM EDT
      • Eastern Massachusetts
         
      • Posts
        979
      • Thanks
        6
      • Thanked
        62

      Roger, it is most likely one of the 3 wires used for the chuff sensing on the cable between the engine and tender.  The 3 wires on the rightmost side of the ender are for chuff  (power, ground, signal)

      the 3 left wires are 2 for track power and one for the rear light on coal tenders.

    • July 9, 2018 9:09 PM EDT
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      Progress report:

      (1) I have determined that the cable from the loco and its female connector are OK as well as the male connector on the tender.

      (2) Regarding the volume control, I found there is a 'dead spot' when the volume control knob is set at maximum volume. Setting the control knob half way between max and min allows for 'sound' to be heard; BUT, the sound is horrible. Sounds like a blast of generic radio static noise. The horrible sound matches whistle start up sound timing as well as the chuff timing but isn't anything similar to normal sounds. I tried connecting the sound output to a different speaker - same terrible noise. A magnet well activate the reed switch module under the front tender axle; but, the whistle is just a blast of static. The bell is somewhat recognizable but definitely not any kind of bell you have ever heard!

      So - any suggestions? Is there a sound generator microprocessor that may be bad?

      Thanks for any help and comments.

      Roger Bush

    • July 10, 2018 5:50 PM EDT
      • Pittsburgh, Pennsylvania
         
      • Posts
        10,049
      • Thanks
        83
      • Thanked
        597

      If the POT (volume control) is bad, then why not just replace that? A bad POT could really mess up the sound it was supposed to control.

      ____________________________________

      Shannon car Shops
      Home of the infamous leg lamp

      I.A.R.R.R. Member #12

      and King Butt Modeler

    • July 10, 2018 8:29 PM EDT
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      David:  I don't follow your logic path. A volume control controls volume of sound. It does not control quality, content or characteristics of sound.

    • July 11, 2018 5:40 AM EDT
      • Pittsburgh, Pennsylvania
         
      • Posts
        10,049
      • Thanks
        83
      • Thanked
        597

      Ok. Replacing the POT may not solve the issue. But, I have seen where a damaged pot caused distortion to the sound, because the pot had an open in it and so it changed the characteristics of the amplifier circuit.

       

      Supposedly Massoth sells the LGB boards, if you want to just replace the whole sound system.

      ____________________________________

      Shannon car Shops
      Home of the infamous leg lamp

      I.A.R.R.R. Member #12

      and King Butt Modeler

    • September 25, 2018 3:31 AM EDT
      • McLean, VA
         
      • Posts
        33
      • Thanks
        0
      • Thanked
        3

      Roger - if the other actions suggested didn’t fix the sound problem, you’ll need to replace the circuit board with decoder such as the ones Massoth makes, e.g., Massoth eMotion DC/DCC Power/Sound Decoder.  You remove the existing circuit board in your LGB loco and re-wire with a new Massoth or other brand decoder.  The older LGB non-D motor blocks with only three wires to for power pickup and motor power don't accommodate a decoder which need four wire connections.

         

      See the Website AllAboutLGB.Com........he's a Massoth product dealer in Baltimore MD.

       

      As a part-time hobby, I also do LGB repairs and decoder installations.......see my website listed below.

       

      You also asked about replacement LGB circuit boards.  Marklin took over LGB in 2007 and they only stock parts for the LGB locos they've made.  So finding anybody that has a new replacement circuit board for your LGB loco is very unlikely.  What you can do is do a search on eBay under "LGB Parts" and there are some folks who take new LGB locos apart and sell them there.  And sometimes a hobbyist will salvage an LGB loco for parts and sell them on the same topic on eBay.  Also there's eBay.de site in Germany, and there are lots of LGB parts, new and used, that dealers and hobbyists sell on that eBay site.  Go to eBay.de, then do a search for "LGB ersatzteile" which is LGB Parts in German.  I've seen some LGB circuit boards for sell there.......just periodically do a search on both sites for your loco's parts as sellers continually update items for sell.  By the way, I use a German to English translator to read the eBay.de postings:  Just do a Google search to find various options.

      Best of luck! 

       

      By the way, here's the LGB Parts Diagram for your loco.........it does have the four pin motor block so fairly easy to install a DC/DCC power/sound decoder.

       

      LGB 23182-1 Parts Diagram.pdf (394.3 Kb)
      This post was edited by Thomas White at September 25, 2018 9:27 AM EDT
      ____________________________________

      Tom White

      LGB Railfan - LocomotivesPro

      https://www.olddominionrailways.com/

       

    • September 25, 2018 8:46 AM EDT
      • Eastern Massachusetts
         
      • Posts
        979
      • Thanks
        6
      • Thanked
        62

      There are many choices for sound and you need to let us know how you plan to run your engine in order for us to help.

      Battery or track powered DC or DCC is what I would ask, and also your price range as you can get a sound for under $100 and all the way up to $250 not including installation.

    • September 25, 2018 1:59 PM EDT
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      Thomas White:

       

      Thanks for your interest in my problem at this late date. Here is what has happened since last July.

       

      At the suggestion of David Maynard in this thread, I acquired a Massoth eMOTION S Decoder. I was attracted to that sound board as the user’s manual states ‘An external pulse (aka chuff) generator is optional as the eMOTION S decoder is capable of producing a pulse by itself’. So I bought one. Well, yes it did generate chuff by itself. But the chuff rate had no relationship to wheel rotation. Also, aside from the unsatisfactory chuff rate, the chuff sounds started before the loco moved and stopped before the loco stopped. In addition to the strange chuff rate, the sound board did not produce the expected sounds of braking, compressor, generator, etc. The user’s manual indicated the board could be programmed to eliminate the “automatic” chuff and allow for connection to a reed switch to use with wheel magnets. So I sent the sound board back for reprogramming. Didn’t get what I requested. The only change was a slightly slower chuff rate and no ability to connect a reed switch. Thinking maybe with the proper equipment I could do the programming myself, I poked around and came to the conclusion that it would take a lot of money to do that. So I just gave up. So now I just start the loco off quickly and stop it suddenly so as not to have to explain to visitors why the chuff is so strange.

       

      Dan Pierce:

       

      I am running on track power.

       

      In retrospect I wish I had bought a Phoenix board or even a MyLocoSound board. If anyone knows of an enthusiastic person with Massoth equipment who could reprogram my board, I would appreciate a referral.

       

      Thanks, Roger Bush

      This post was edited by Roger Bush at September 25, 2018 2:00 PM EDT
    • September 25, 2018 5:43 PM EDT
      • McLean, VA
         
      • Posts
        33
      • Thanks
        0
      • Thanked
        3

      Roger Bush said:

      Thomas White:

       

      Thanks for your interest in my problem at this late date. Here is what has happened since last July.

       

      At the suggestion of David Maynard in this thread, I acquired a Massoth eMOTION S Decoder. I was attracted to that sound board as the user’s manual states ‘An external pulse (aka chuff) generator is optional as the eMOTION S decoder is capable of producing a pulse by itself’. So I bought one. Well, yes it did generate chuff by itself. But the chuff rate had no relationship to wheel rotation. Also, aside from the unsatisfactory chuff rate, the chuff sounds started before the loco moved and stopped before the loco stopped. In addition to the strange chuff rate, the sound board did not produce the expected sounds of braking, compressor, generator, etc. The user’s manual indicated the board could be programmed to eliminate the “automatic” chuff and allow for connection to a reed switch to use with wheel magnets. So I sent the sound board back for reprogramming. Didn’t get what I requested. The only change was a slightly slower chuff rate and no ability to connect a reed switch. Thinking maybe with the proper equipment I could do the programming myself, I poked around and came to the conclusion that it would take a lot of money to do that. So I just gave up. So now I just start the loco off quickly and stop it suddenly so as not to have to explain to visitors why the chuff is so strange.

       

      Dan Pierce:

       

      I am running on track power.

       

      In retrospect I wish I had bought a Phoenix board or even a MyLocoSound board. If anyone knows of an enthusiastic person with Massoth equipment who could reprogram my board, I would appreciate a referral.

       

      Thanks, Roger Bush

      ------------------------------------------------------------------------------- 

      Roger - Sorry to hear about your frustrating experience.  The Massoth products are top notch and they are very programmable, but to do so, the decoder needs to be installed in a locomotive (called a motor load on the decoder) so the CVs can be adjusted by watching and hearing the locomotive operate on a programming track.  I'm retired, and as a hobby, I install various brands of DC/DCC decoders into locomotives, including Massoth, Soundtraxx, Phoenix, Piko, and LGB.......see my Website link under my posting's signature.  Sending just the decoder back to the seller to do the adjustments won't do the trick.  And you do need the appropriate DCC equipment to program the CVs.......I use both a Massoth Central Station and a Piko Central Station (made by Massoth) which will program most DCC-compliant decoders.

       

      You're correct, the Massoth eMotion S Sound Decoder can produce the chuff for a steam locomotive using either the embedded decoder technology, or optionally, installing an eMotion Pulse Generator that take a lot of work to install a replacement axle in your loco's motor block.......complicated and a lot of work, doesn't fit all locos.  The easiest approach to fix your chuff rate issue is to match the wheels' revolutions (synchronization) using CVs 195 - 198, as appropriate........see the pages 30 - 31 in the Massoth Configuration Manual for XLS, LS, and S Decoders that came with your S Decoder.  You may be able to find a large scale club in your area where a member with DCC equipment could adjust your loco's installed decoder for you to improve the chuff rate synchronization with the loco's wheel revolutions/loco's movement.  There are also repair shops, like myself, that will install decoders into locomotives for a fee and can do the DCC CV adjustments.......I focus primarily on LGB locomotives.  Note that using DC/DCC  installed sound decoders on a DC/Analog-powered layout won't operate/sound quite as well as on a DCC/Digital layout; the decoders are designed primarily for DCC/Digital operation and many decoder manufacturers directly state that in their decoders' literature.

       

      I'm sure Dan Pierce will also respond to you with his thoughts. 

       

       

       

      This post was edited by Thomas White at September 25, 2018 5:55 PM EDT
      ____________________________________

      Tom White

      LGB Railfan - LocomotivesPro

      https://www.olddominionrailways.com/

       

    • September 25, 2018 9:04 PM EDT
      • Carlsbad, CA
         
      • Posts
        7,772
      • Thanks
        117
      • Thanked
        542

      Without a chuff switch, the Phoenix would also not match the revolutions.

       

      Bottom line, without a chuff switch, you need to program the decoder to match your loco, and it takes a DCC system in most cases. You can buy a DCC system for about $160 that will do this for you.

       

      Sending the decoder away without the loco, no one could set the chuff rate exactly.

       

      Greg

      ____________________________________

      Be sure­ to visit ­my site, l­ots of tec­hnical tip­s and modi­fications,­ and you c­an search ­for topics­ and key w­ords.


      ­Click HERE for Greg­'s web sit­e
      PLEASE NOT­E: Please do NOT use private messaging, i­f you have­ a questio­n, feel fr­ee to emai­l me priva­tely, u­se regular­ email onl­y: greg@el­massian.co­m

    • September 25, 2018 10:43 PM EDT
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      Greg Elmassian:

       

      Without a chuff switch, the Phoenix would also not match the revolutions.

       

      Of course! I have Phoenix sound boards with reed switch and magnet arrangements. So I know about that.

       

      Bottom line, without a chuff switch, you need to program the decoder to match your loco, and it takes a DCC system in most cases. You can buy a DCC system for about $160 that will do this for you.

       

      As I said I looked into that. Massoth/Piko equipment would cost more like $350. Not an option since I already have $200+ invested in a board that is unsatisfactory. I would rather buy a Phoenix board for ~$160 and trash the Massoth board.

       

      Sending the decoder away without the loco, no one could set the chuff rate exactly.

       

      I didn't ask for that or expect that. I asked for the board to be reprogrammed to eliminate the "automatic" chuff and allow for a reed switch/magnet arrangement. I didn't get that.

       

      Thomas White:

       

      Thanks for your detailed response. No, I didn't want to get tangled up trying to adapt a Massoth eMOTION Pulse Generator to my loco. All I wanted was to disable chuff from track power and enable chuff from GND and Clock 2 solder pads. Since you are familiar with Massoth, you know what I am talking about. That would allow me to implement the reed switch/magnet arrangement with which I am familiar. If you could do that for me, I would be very appreciative.

       

      Thanks, Roger Bush

    • September 25, 2018 11:12 PM EDT
      • Carlsbad, CA
         
      • Posts
        7,772
      • Thanks
        117
      • Thanked
        542

      OK, so maybe I am confused.... when you purchased the decoder... did you request it be set up for a chuff switch?

       

      Clearly as delivered to you it was not so configured.

       

      But it seems you blame Dave for the suggestion and delivery of a decoder not properly configured to your taste.

       

      Then you sent the board back for reprogramming, but apparently it was still not configured for an external chuff switch input.

       

      What does your dealer say? Will he take it back and set it up properly this time?

       

      Somehow it sounds like there was a breakdown in communication between you and your dealer, twice.

       

      So, unless Dave is your dealer, I'm confused why you seem upset?

       

      If it was me, I would demand the dealer set it up for a simple chuff switch, unless this service was clearly an extra cost option.

       

       Greg

       

      p.s. If this is merely changing a CV in the decoder (appears to be CV 195 based on this manual: http://www.allaboutlgb.com/pdfs/Massoth%20eMOTION%20XLS%20Decoder%20User%27s%20Manual%20V250.pdf) then it should be simple. The manual recommends a hall effect sensor as opposed to a simple reed). The $150 DCC system I mentioned by NCE (PowerCab) will do this programming. If you can confirm that a reed will work, let me know, I'll program it for you for the cost of a USPS flat rate small box (under $8)... contact me by email greg@elmassian.com if this would be a solution.

      This post was edited by Greg Elmassian at September 25, 2018 11:38 PM EDT
      ____________________________________

      Be sure­ to visit ­my site, l­ots of tec­hnical tip­s and modi­fications,­ and you c­an search ­for topics­ and key w­ords.


      ­Click HERE for Greg­'s web sit­e
      PLEASE NOT­E: Please do NOT use private messaging, i­f you have­ a questio­n, feel fr­ee to emai­l me priva­tely, u­se regular­ email onl­y: greg@el­massian.co­m

    • September 26, 2018 6:58 AM EDT
      • McLean, VA
         
      • Posts
        33
      • Thanks
        0
      • Thanked
        3

      Greg - Your offer to program Roger's decoder for him is very commendable........a super nice gesture.

      ____________________________________

      Tom White

      LGB Railfan - LocomotivesPro

      https://www.olddominionrailways.com/

       

    • September 26, 2018 7:40 AM EDT
      • Eastern Massachusetts
         
      • Posts
        979
      • Thanks
        6
      • Thanked
        62

      I use zimo decoders and the chuff can be selected by reed switch sensor or by motor back EMF (BEMF).  BUT the rate by BEMF needs a DCC system to set it to the right value to match the wheel rotation in CV 267 and this can only be done on a DCC system while running the engine.  I do this for myself and club members and Trainli installs.

      Also, the Phoenix $160 sound unit I thought is for DCC, for analog operation you need the version that is near $250.

    • September 27, 2018 2:26 AM EDT
      • Carlsbad, CA
         
      • Posts
        7,772
      • Thanks
        117
      • Thanked
        542

      I'm working offline with Roger... at first glance it appears there is a discrepancy between the way the decoder is working and the sheet provided with it that lists the CV settings... when I get it solved I will report back.

       

      Greg

      ____________________________________

      Be sure­ to visit ­my site, l­ots of tec­hnical tip­s and modi­fications,­ and you c­an search ­for topics­ and key w­ords.


      ­Click HERE for Greg­'s web sit­e
      PLEASE NOT­E: Please do NOT use private messaging, i­f you have­ a questio­n, feel fr­ee to emai­l me priva­tely, u­se regular­ email onl­y: greg@el­massian.co­m

    • November 27, 2018 8:43 PM EST
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      Well, despite an epic effort of work by Greg on my Massoth eMotion S Sound Decoder to reprogram it to eliminate the "automatic" chuff and allow for a reed switch/magnet arrangement, it didn’t happen. Greg is now of the opinion that the decoder has defective firmware and/or software. The dealer does not respond to my emails asking for resolution of this issue. So it looks like I have a $230 +/- decoder likely destined to go to a landfill.

       

      If you are interested in this saga, you might like to see a blow-by-blow discussion of Greg’s efforts on:

       

      https://www.gscalecentral.net/threads/cannot-stop-autochuff-massoth-emotion-s.311887/

       

      as well as his personal diary of his efforts on his websire:

       

      https://elmassian.com/index.php/dcc/specific-manufacturers/massoth

       

      So – I guess that brings this thread up to date.

       

      I am extremely grateful that Greg took such an intense interest in my dilemma. I cannot thank him sufficiently.

       

      Roger Bush

    • November 28, 2018 12:50 PM EST
      • McLean, VA
         
      • Posts
        33
      • Thanks
        0
      • Thanked
        3

      Roger - Where did you buy the Massoth eMotion S Sound decoder?  Did you ask them for technical advice on how to adjust the CVs on the decoder?  I'm sure there's a way to deactivate the S decoder since there are options for connecting a Massoth Pulse Generator to synchronize the sound and pulsed smoke with the rotation of the locomotive's wheels.  

      I suggest you send an email to Mohammed, the main Massoth retailer here in the USA...…….he can answer your question on which CV to deactivate the built-in chuff:  info@AllAboutLGB.com  I'm not knowledgeable with that particular Massoth decoder so I can't answer your question.  But you'd need a digital DCC system, or get someone who has one, to make the CV adjustments to the decoder.  Instead of using the Massoth S decoder, I would have just removed the old LGB electronics (circuit board/sound board) and replaced them with the Massoth eMotion XLS power/sound decoder...…..about the same price you paid for the S version.  The Massoth XLS works well on either Analog/DC current or Digital/DCC current...….but again to adjust the CVS, if you needed to do so, you'd need to use a DCC system, or use a Massoth DiMax PC Module Unit that connects to a PC and allows you to change the CVs on a Massoth decoder, updating the sound file, etc.

      Tom

      ____________________________________

      Tom White

      LGB Railfan - LocomotivesPro

      https://www.olddominionrailways.com/

       

    • November 28, 2018 5:55 PM EST
      • Ruidoso, NM
         
      • Posts
        11
      • Thanks
        0
      • Thanked
        0

      Tom – I’d rather not name the dealer. I didn’t ask for technical advice as I don’t have the equipment to change CVs. The decoder was sent back to the dealer to deactivate the automatic chuff and activate the chuff for reed sensors. He didn’t/couldn’t do that. Greg with all of his equipment and skill was unable to do it. Hence Greg’s opinion that the decoder is defective.

      Roger Bush

Forums General Problem Solving

    Icon Legend

  • Topic has replies
    Hot topic
    Topic unread
    Topic doesn't have any replies
    Closed topic
    BBCode  is enabled
    HTML  is enabled

Add Reputation

Do you want to add reputation for this user by this post?

or cancel

Ads by Google